Site won't allow editing

Alan German
Sun, 10 Aug 2003 22:26:07 -0400

For the Manila users on my systems that report this problem, I suggest 
the possibilities that their browser and/or their personal firewall 
and/or their ISP is blocking the referer header in the http request 
that submits your edit. Manila expects the referer to be valid as a way 
to prevent spoofing.

I recommend that users check their browser settings (I think only IE on 
Windows has this level of control) or use a non-MS browser, check their 
personal firewall settings (if used; you note you recently removed it, 
but are you positive?), or contact their ISP and ask if they block 
referer headers. Some ISPs block referer headers in an attempt to 
guarantee privacy [at the risk of breaking systems that rely on referer 
for security purposes].



On Sunday, August 10, 2003, at 09:34  PM, Dean Landsman wrote:

> Hi, Jim
> Tried it that way, still got the same message.  Getting this on ALL the
> sites where I am a managing or contributing error.
> A similar problem occurred when I was using Norton Firewall, which is 
> no
> longer on the machine.
> Many net-connectivity oddities are occurring of late, perhaps 
> connected to
> the pending Verizon strike.
> Still can't edit any of my blogs, though, at this time.
> HELP!!!
> Thanks.
> --Dean
> -----Original Message-----
> From:
> []On Behalf Of Byrne Jim
> Sent: Sunday, August 10, 2003 5:46 AM
> To: ''
> Subject: RE: Site won't allow editing
> Dean,
> Is your site set up for static rendering? If so, make sure the url 
> value for
> your static site setup ends with a slash, i.e.
> rather than
> All the best,
> Jim
> -----Original Message-----
> From: Dean Landsman
> To:
> Sent: 8/10/03 12:38 AM
> Subject: Site won't allow editing
> Tried a number of times to edit the sidebar (blogroll) and got this
> message:
> ---------------------------------------
> Sorry! There was an error: Can't evaluate the expression because the
> name
> "referer" hasn't been defined.
> The error was detected by Frontier 9.0 in mainResponder.respond.
> Webmaster:
> Time: Sat, 09 Aug 2003 23:35:04 GMT.
> -------------------------------------
> It sees me as an editor, lets me into the area to make the edits, but
> then
> the above occurs.
> Any ideas?  Thanks in advance.
> --Dean